Bug 29 - terminatorX 3.8.3-1 segfaults on start-up
: terminatorX 3.8.3-1 segfaults on start-up
Status: RESOLVED FIXED
Product: terminatorX
Classification: Unclassified
Component: software
: 3.83
: PC Linux
: P1 critical
Assigned To: Alexander Koenig
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-15 12:27 CEST by momits
Modified: 2011-11-27 20:44 CET (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description momits 2011-06-15 12:27:45 CEST
How to reproduce:
1. Install the TerminatorX-rpm-package in Fedora 15 (64 bit) -> '3.8.3-1 x86_64'
2. Start jackd 1.9.7
3. Run terminatorX from a terminal
4. You get the error message: 'Segmentation fault'
5. dmesg says:
[ 4953.200054] terminatorX[2631]: segfault at 0 ip 0000003fa6068283 sp 00007fff3e313d38 error 6 in libstdc++.so.6.0.16[3fa6000000+e8000]

For me this happens every time I try to open terminatorX. This is possibly a Fedora 15 related bug, because I had Ubuntu 10.04 installed before and there were no problems.
Comment 1 Tim Radigan 2011-09-14 21:55:15 CEST
Same issue over here.  Running Fedora 15 x64 and terminatorX seg faults as soon as you launch it.. 

I am really hoping to try terminatorX out.  If this bug could be escalated and/or figured out, it would be greatly appreciated.
Comment 2 kfrancist 2011-11-13 02:08:16 CET
i'm having this same problem using ubuntu 11.10.
Comment 3 Alexander Koenig 2011-11-13 11:11:39 CET
Confirmed with Ubuntu 11.10 on 64 bit platform. Looks like a g++ anomaly, the tX code that triggers the crash seems OK. Currently working on a workaround.
Comment 4 Alexander Koenig 2011-11-13 14:16:39 CET
New release 3.84 is now available on terminatorX.org which has a work around for this regression. Tested on Ubuntu only but the Fedora issue seems identical, so it should be resolved, too. Let me know if this is not the case, thanks!
Comment 5 Alexander Koenig 2011-11-13 14:23:30 CET
*** Bug 27 has been marked as a duplicate of this bug. ***
Comment 6 momits 2011-11-25 20:46:31 CET
Thank you very much for your efforts! Unfortunately I didn't find any rpm packages on planet ccrma, is this going to be updated?
If there isn't an rpm available soon, I'll compile terminatorX myself to check whether it is working.
Comment 7 Alexander Koenig 2011-11-27 15:55:53 CET
There is a new build available at RPM Fusion:
http://download1.rpmfusion.org/free/fedora/updates/testing/16/i386/repoview/terminatorX.html
Comment 8 momits 2011-11-27 20:44:25 CET
It is working flawlessly! Thanks.