Bug 9 - midi input port doesnt advertise well, external midi recorders cannot use tX to play
Summary: midi input port doesnt advertise well, external midi recorders cannot use tX ...
Status: RESOLVED WORKSFORME
Alias: None
Product: terminatorX
Classification: Unclassified
Component: software (show other bugs)
Version: 3.80
Hardware: PC Linux
: P1 major
Assignee: Alexander Koenig
URL:
Depends on:
Blocks:
 
Reported: 2004-08-25 15:24 CEST by Charles
Modified: 2007-08-20 13:40 CEST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Charles 2004-08-25 15:24:37 CEST
the midi input port of tX dont seem to advertise themselves well.

 It seems there is a problem with tX input midi port. The problem shows up when
trying to send a midi track to tX from rosegarden. Other synths appear in the
play midi external devices, but no tX

 Doesnt matter if i plug it directly thru qjackctl. Doesnt matter if i start tX
after or before rosegarden.

 Havent tried other midi recorders like muse

 As a consequence of this, tX cannot be used for the moment for session
recording, unless one uses an audio track for it, lossing all the benefits of a
midi track

   ---  ---  ---

 in case you dont have experience with rosegarden, open rosegarden. Go to Studio
->Manage MIDI devices.
 
 There are two windows; play devices and record devices. In this case one wants
that a previously recorded midi track is now played with tX as a synth. So tX
should appear in the play devices. Open any other synth (zynaddsubfx for
example). It appears in there.
Comment 1 Alexander Koenig 2004-08-26 14:54:34 CEST
First of thanks for your bug report, Charles - i would have replied to those
emails, too btw - Anyway on to the bug, I don't have rosegarden installed so
what I'd like to know is whether you're tX-MIDI-in works at all. Please, if you
can, run terminatorX (built with ALSA MIDI in enabled) and run 'aconnect -o'.
You should see terminatorX client there with one writeable port.

Please let me know the output of your aconnect -o run. Thanks,
Alex
Comment 2 Charles 2004-08-26 16:46:16 CEST
$ aconnect -o
client 64: 'EMU10K1 MPU-401 (UART) - Rawmidi 0' [type=kernel]
    0 'EMU10K1 MPU-401 (UART)'
client 65: 'Emu10k1 WaveTable' [type=kernel]
    0 'Emu10k1 Port 0  '
    1 'Emu10k1 Port 1  '
    2 'Emu10k1 Port 2  '
    3 'Emu10k1 Port 3  '
client 129: 'terminatorX' [type=user]
    0 'Control Input   '
Comment 3 Alexander Koenig 2004-08-26 17:12:55 CEST
Thanks for the output, basically this means, there is no bug - terminatorX can
do no more to "advertise" the port - it should be just as visible as your emu10k
ports - if you see those in rosegarden you should see the tX "Control Input"
port as well. Hmm, maybe it's some property of the port that rosegarden
inspects, I will try to install rosegarden (if it's in Debian unstable) when I
get home for a quick test, but from the tX point of view we have no bug here.
Comment 4 Alexander Koenig 2004-08-26 20:54:48 CEST
The Rosegarden main site seems to be down currently, and the package in Debian
is broken (faulty libopenexr0 dependency). However tX's midi port is visible in
muse in qjackctl and muse.
Comment 5 Charles 2004-08-26 22:17:58 CEST
 yes, on the Rosegarden mailing list i was just told that this is a current
issue with their jack interface, i assumed that since RG worked with some synths
well and others not the fault was on the synth

 sorry for the bother
Comment 6 Alexander Koenig 2004-09-12 12:43:01 CEST
Now that Debian Sid's rosegarden4 (0.9.9) finally installs, I had the chance to
test your issue - and it works for me: run terminatorX, run rosegarden4, select
Tracks/Set Instrument/MIDI software device and a midi channel of your choice.
Then you will see "Control Input" in the track's instrument section. This is the
expected behavior. The only thing rosegarden could do to improve this, whould be
using the actual ALSA client name "terminatorX" instead of "MIDI software
device" but that is just a minor issue.

So I'll close this bug as I cannot reproduce it. If you can provide more data to
reproduce your problem, please feel free to re-open it.