Update deprecated gtk3 code.